CRM - Users Unable to Log In

Incident Report for DealerSocket Status Page

Resolved

We have resolved an issue where users have reported errors logging in and slow navigation within the CRM.
Posted Sep 13, 2026 - 18:05 PDT

Monitoring

We are currently monitoring an issue where users have reported errors logging in and slow navigation within the CRM.
Posted Sep 12, 2026 - 16:09 PDT

Investigating

We are currently investigating an issue where users are unable to access the CRM platform.
Posted Sep 12, 2026 - 14:38 PDT
This incident affected: CRM (CRM, Mobile CRM Application, Revenue Radar).