IDMS System Slowness,
Incident Report for DealerSocket Status Page
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 09:36 PST
Investigating
Teams investigating reports of slowness and searching issues in IDMS application
Posted Feb 19, 2021 - 09:14 PST
This incident affected: DMS (IDMS).